This page is a part of XConnectPro online Help Manual.
XConnectPro is X Server for windows by Labtam bringing your PC to Unix and X-Windows. Visit Home of X Server for windows for more information.



Telnet Menu Options

The Telnet menu bar displays five items: Commands, Edit, Options, View, and Help. They are described below.


The Help Menu

The Help menu contains the following menu commands:

Contents

Displays the Telnet help file.

About

Displays copyright, version and program information about Telnet.


The Commands Menu

The Commands menu contains the following menu commands:

Connect

The Connect item displays the Telnet Connect Host dialog box so you can specify the remote system you want to communicate with. You can also connect to a port or service to use other than the standard Telnet port. This is useful when the Telnet client is being used to access something other than a Telnet daemon.

This command is not available when you are already connected to a remote system.

Once you connect to the remote system, the title bar in the Telnet window shows the remote system name.

Disconnect

The Disconnect item ends the connection to a remote system so you can connect to another system or end your session. This command is not available when you are not connected to a remote system.

Interrupt Process

This command sends the Telnet Interrupt Process command (IP control function) to the remote host. This command (which suspends, interrupts, aborts, or terminates the operation of a user process) tells the host to stop the current process to which the terminal is connected. This function is frequently used when a user believes his process is in an unending loop, or when an unwanted process has been inadvertently activated.

Abort Output

This command sends the Telnet Abort Output command (AO control function) to the remote host. This command tells the host to run to completion the current process, which is generating output, but without sending the output to the user's terminal from the host. Further, this function typically clears any output already produced but not yet actually sent to the user's terminal.

Break

This command sends the Telnet Break command (BREAK control function) to the remote host. This command (intended to indicate that the Break Key or the Attention Key was hit) tells the host to stop what it is doing.

Are You There

This command sends the Telnet Are You There command (AYT control function) to the remote host. This command determines if the connection with the host is still up and the system is running. This command tells the host to send back to the user's terminal some visible evidence that the command was received. This function may be invoked by the user when the system is unexpectedly 'silent' for a long time, because of the unanticipated (by the user) length of a computation, an unusually heavy system load, etc.

Pause Output

This command pauses output (it sends Ctrl+S to the host). The Resume Output item then becomes active and can be selected.

Resume Output

This command resumes output (it sends Ctrl+Q to the host) after output has been paused.

Exit

The Exit item terminates the Telnet session.


The Edit Menu

The Edit menu displays two commands that allow you to edit the lines you type in a Telnet window: Erase Character and Erase Line. Also there are two standard commands, Copy and Paste, for text operations with the Microsoft Windows' clipboard.

Erase Character

The host should delete the last preceding undeleted character or print position from the data stream being supplied by the user. A print position may contain several characters that are the result of overstrikes, or of sequences such as <char1> BS <char2>...

Erase Line

The host should delete all the data in the current line of input, i.e. characters from the data stream back to, but not including, the last CR LF sequence sent over the TELNET connection.

Copy

To copy text onto the clipboard, leaving the original text intact and replacing the previous clipboard contents, select the text you want to copy, and choose Copy. This command is unavailable until you have selected text.

Paste

When there is text in the clipboard, you can use Paste to insert a copy of the clipboard contents at the insertion point to the Telnet window, or to another Microsoft Windows application. This command is not available if the clipboard is empty.

There are several ways in using Copy and Paste. The first example will be to show using your mouse.

  1. In your Telnet window, scroll over with your mouse to the text you want to select.
  2. Then click your left mouse button and hold it down to select the text you want to copy.
  3. Once the text has been highlighted in a box frame, right click your mouse button to see the Copy to clipboard option, and then click on this button.
  4. Your text has now been copied to the Microsoft clipboard, and you can now choose where you want to paste it.
  5. Click on where you want the text to be pasted, and then right click on the mouse and click on the Paste from clipboard button. The original text that you copied was now pasted into the area you selected.

The second example will be to show using Menus.

  1. With the same text to copy, you can highlight the text again. You will see a solid clear box appear around the selected text.
  2. Click on the "Edit Menu" and then click on "Copy". This has now copied the selected text to the clipboard.
  3. Now click to where you want the copied text pasted to. Click on the "Edit Menu" again and then click "Paste". This will paste the text into your chosen location.

To Copy and Paste, you can also use key combinations, "Ctrl+C"/"Ctrl+V" or "Ctrl_L+Shift_L+C"/"Ctrl_L+Shift_L+V".
For more information, see settings CtrlCVmode and QuickClipBoard.

See also settings SelectRect and FineSelectMode that you can use to specify different modes for text selection in your Telnet window.

Save ExtScreen

  • To File
    This option lets you save the output buffer of your session into a file.


  • To Clipboard
    This option lets you send the output buffer of your session to Clipboard.


  • To File and View
    This option allows you to save the output buffer of your session into a file and then to invoke Notepad for you to view or edit the text.

    For example, to save a Telnet screen that you want to be written to a file, do the following as you are working in your Telnet window:
    1. Click on "EDIT", then click on "Save ExtScreen" and then click on "To File and View".
    2. Then choose which location you want to save the file to and also what name you want to call the file.
    3. After entering the file name and location where you are saving the Telnet screen, press the Save button. After this the screen shot has been saved. Then you will see a Notepad window with the screen content appear.

The View Menu

With options from this menu, you can navigate through the output buffer of your session. For additional information, refer to subsection Details of a Session in section Starting and Terminating Telnet.

The Actual Screen is the one that always displays the last line of the session's output. In this screen, you can only input your commands.

The First Extend Screen option displays lines for the first screen of the output buffer. The Prec Extend Screen option displays lines for the preceding screen (if any) from the current one. The Next Extend Screen option takes you to the next screen (if any) from the current one.

These options are only used for reviewing (not for entering) information and moving to screens. They suspend output into the output buffer and disable your input. To resume output and enable input, use the Actual Screen option.

To navigate through the output buffer, you can also use the Notepad-like view-key combinations.

The Find option lets you search text in the output buffer like you do that when using Notepad.


The Options Menu

Telnet allows you to personalize your settings and automatically use them every time you establish a connection to a remote computer. This is accomplished by storing your personalized settings in the corresponding ini-files. The Options menu displays items that you can choose to specify particular implementations of Telnet. Normally they do not have to be changed.






Home | Product | Download | Order Now | Upgrade | Support | Pricing | Company Information | Contact Us


Labtam Copyright 1999 - 2009 LabtamTM Inc.