This page is a part of XSecurePro online Help Manual.
X-SecurePro is X-Server for windows by Labtam bringing your PC to Unix and X-Windows. Seamless Secure integration from PC to Unix and X-Window System. Bringing Maximum Security while still finding all of the standard access of X11, TCP/IP, FTP, TFTP, LPR, TELNET, NFS and SSH. Visit Home of X Server for windows for more information.



XServer Commands

In the Multiple and Full Screen modes, XServer commands are displayed by clicking on the X-session icon.

In the Single mode, XServer commands can be accessed by clicking on the Control Menu box at the top left corner of the X-session window.

The top of the Control Menu presents the standard MS Windows commands (Restore, Move, Size, Minimize, Maximize, and Close).

The bottom of the menu presents XServer commands. They are described below.


The Edit Menu

When you select Edit, the Edit Menu commands are displayed:

All available Edit commands are described below.

The first item shows you the current X Selection.

Note: Whenever X Selection is the source or target of a copy or paste command, you can define the X Selection being used with the Options-X Selection menu item. This item is described in A Note on Copy and Paste and The Options Menu sections in this chapter.


Copy Rectangle

This command is available in the Single mode only. It copies a rectilinear area you select on any visible part of the X-session window (i.e. a pixel image) to the MS Windows Clipboard (regardless of the ConnectXWClipboards setting). When you choose this item, a camera icon is displayed. Click (and hold down) the left mouse button at the rectangle's origin and drag the mouse to define the rectangle. As you drag the mouse, lines will delineate the rectangle to be copied. When you release the left mouse button, the selected rectangle will be copied to the MS Windows Clipboard. You can then save and paste this image from the MS Windows Clipboard into programs running under MS Windows that support bitmap paste.


Print Rectangle

This command is available in the Single mode only. It prints a rectilinear area you select on any visible part of the X-session window (i.e. a pixel image). When you choose this item, a camera icon is displayed. Click (and hold down) the left mouse button at the rectangle's origin and drag the mouse to define the rectangle. As you drag the mouse, lines will delineate the rectangle to be printed. When you release the left mouse button, the selected rectangle will be printed (after you will select your target printer).


Copy All

This command is available in the Single mode only. It copies all visible parts of the X-session window (i.e. a pixel image) to the MS Windows Clipboard (regardless of the ConnectXWClipboards setting). You can then save and paste this image from the MS Windows Clipboard into programs running under MS Windows that support bitmap paste.


Copy X Selection

This command copies text and graphics from the current X Selection to the MS Windows Clipboard (regardless of the ConnectXWClipboards setting). You can use an X client's selection procedure to select the data you want to copy. Once data is in the Clipboard, you can use the Clipboard to save data or paste it into any MS Windows application that supports copy and paste.


Paste to X Selection

When you choose this command, text or graphics that is in the Microsoft Windows Clipboard is pasted to the current X Selection (regardless of the ConnectXWClipboards setting). You can then use an X client's paste procedure to paste the data into an X client.

This function works for both text and graphics, although many clients do not support graphics.


Copy X Selection to File

This item lets you save any text that is in the current X Selection to a file on your PC. You can use an X client's selection procedure to select the data you want to copy. When you select the item, you will be prompted for the name of the file you want to save the data to. When you click OK, the current X Selection will be copied to the specified file.


Paste File to X Selection

This item lets you paste any text file that is on your PC to the current X Selection. When you select the item, you will be prompted for the name of the file you want to paste. When you click OK, the specified file will be pasted to the current X Selection. You can then use an X client's paste procedure to paste the X Selection into an X client.


Clear X Selection

This item will be grayed unless XServer has control of the X Selection.

Whenever you choose the Paste to X Selection or Paste File to X Selection commands, XServer takes control of the X Selection. You can use the Clear X Selection function to clear the buffer and free the memory required to maintain it.

Note: This function can also be performed by making another selection in an X client application.


The Options Menu

The Options menu controls options that affect the operation of XServer as a whole. When you select Options, the Options Menu commands are displayed:

All available Options commands are described below.


X Selection

This option determines an X Selection that will be used by the XServer's Copy X Selection, Paste to X Selection, Copy X Selection to File, Paste File to X Selection and Clear X Selection commands of the Edit menu.

Whenever you select this option, a dialog box appears on your display prompting you to specify which X Selection you want to used. The current choice will appear at the top of the Edit menu. Use the mouse to select the choice you want from the list box and then click OK.

Most X applications use PRIMARY. For X clients that support SECONDARY, CLIPBOARD, or CUT_BUFFER0 through CUT_BUFFER7, you can change the current X Selection by selecting it from the list.

Note: you can also use the edit field at the top of the dialog box to enter a name for a custom X Selection. This is only useful if the name is defined by an X client. If you do this, the name will be saved and will appear in the dialog box whenever you select this option.


Minimize on Activity Losing

This option is only available in the Full Screen mode. If you select this option, the XServer's window will be iconified each time the focus changes to another window. Otherwise, it can be obscured by other windows.


Enable Animation

The Enable Animation mode provides careful operations with colors while drawing. Note that this mode decreases performance of XServer.


Local NumLock Processing

If this option is enabled, then XServer will process numeric keypad keys, depending on the (local) NumLock key state, and results will be sent to X clients. Otherwise, X clients process the keys (remotely).


Unlock NumLock

This option corresponds to the Unlatched NumLock check box in the XSettings window. If this option is enabled, XServer will consider the NumLock key as a normal key (non-toggling). The NumLock key is unlocked by default. This option was implemented to suppress the NumLock state's influence on some X-window managers and programs.


If Colormap Changed

The If Colormap Changed menu lets you specify XServer response to the hardware colormap (Windows system palette) changes. An X client can require installing its own colormap into the hardware colormap when the user indicates that the application should be active. When this occurs, all other applications can appear in false colors. As soon as you change input focus to another X client, you expect to see right colors displayed in its windows as well as windows using the same colormap as the X client.

XServer regenerates colors of windows using a policy specified by one of the following options:

Redraw

This option causes redrawing the active X client windows as well as windows using the same colormap as the X client.

Update Colors

If you choose this option, XServer will directly update the colors in all the X client windows when you activate an application that requires changing the hardware colormap. The option provides a reasonable compromise between performance and color accuracy.

Note that this option is not supported by some video drivers.

If you do not check any of these options, XServer will do nothing to regenerate colors of windows when changing the hardware colormap. The colors displayed in all the X client windows will potentially be incorrect until the windows update their display. You can redraw all X client windows by choosing the Refresh or Local Refresh item from the XServer's Control Menu.


Move Window to (0,0)

Implemented in the XServer/Multiple Control menu, this option allows users to move any window to the upper left corner of the Windows screen. This feature is useful to view an invisible window when it is out of the visible screen.


Connect LbxLoxy Server

The LbxLoxy Server is a Low BandWidth X proxy derived from sources of the lbxproxy (included in XFree 4.10). In addition to its original capabilities, LbxLoxy can wait for connection to a remote X server instead of initiating the connection itself. Thus, when external connections to XServer are prohibited (e.g. by a firewalling proxy) XServer can initiate a connection to a listening socket for LbxLoxy.

Connection to the running remote LbxLoxy Server may be done through either the direct access insecure channel mode or the secure (SSH) channel mode. See section Using LBX below on how to use Low Bandwidth X (LBX) network-transparent protocol for running X Window System applications.

When you click the Connect LbxLoxy Server item, the Connect Remote LbxLoxy dialog box will appear.

You can see a list of actual SSH1/SSH2 connections you have previously established (for example, by the SSH1 or SSH2 Client of the Telnet_SSH program). (See Starting an SSH Session in section Starting and Terminating Telnet_SSH on how to establish secure connections). The Refresh button allows you to renovate the list.

If you want LBX operations to be done in secure connection mode, select a desired remote host (an active SSH server) from within the list and enable the Use SSH Forwarding check box. In the SSH1/SSH2 mode, the "Dynamic Port Forwarding" feature of the Telnet_SSH/SSH1 or Telnet_SSH/SSH2 Client and XServer will automatically be used, so you need not set up any port forwarding manually.

If you disable the Use SSH Forwarding check box then the direct access insecure mode will only be used for LBX operations.

If the LBX server and SSH server you are using in the X-session are on the same remote host then the Host field can contain "localhost" or "127.0.0.1". This is more preferable than its actual IP address in most cases (but depends on how the host has been configured).

In the Port field, you specify a port number that will be listening for connection from XServer (default is 6163).

Open a login session on a remote host.

Run lbxloxy on the remote host with option '-waitXServer[:port]' where port is a port number that will be listening for connection from XServer (default is 6163):

$ ./lbxloxy -waitXServer:6163 &

or (default)

$ ./lbxloxy -waitXServer &

When connection is established, lbxloxy will open a display port for listening (default is 6163). For convenience, you may set the DISPLAY environment variable:

$ export DISPLAY=:63.0

After that, you are able to run your remote X application(s).


The Macros Menu

This menu lets you create macro-files to remember sequences of your keystrokes. A sequence of remembered keystrokes is called a keystroke macro. Then, whenever you want, you can play back these keystroke macros in a target application window by choosing an appropriate macro-file. Keystrokes are remembered in macro-files as ASCII strings in a special syntax, so you can use text editors (e.g., Notepad) to edit the files. By default, macro-files have the .mac extension and reside in the package's home directory.

Record Macro

When you click on this item the standard Save As dialog box named as File for Macro Recording appears. You can specify a macro-file name you want to record macro to. Pressing Save opens the specified file for writing and turns on the record macro mode. Then, in the target application window (e.g., Terminal), you perform the keyboard actions you want remembered. The mode is effective until you click on the Stop Macro item on the Macros menu or in the Macro recording is running information box, which indicates that the mode is on. Before using the Record Macro option get your target application to the point where you are ready to type the first keystroke of the macro.

Play Macro

This option lets you select a macro-file you want to play back. When you select a file from the macro-file list it is played back immediately in the active X client's window (with actions depending on the application type, e.g., Terminal or Text Editor). If a macro was created for a particular application, you can play it back whenever you are working in that application. Before using the Play Macro option get your target application to the point where you want to play back the macro.

Stop Macro

You use this option when you have finished the last keystroke of the action you want to record. This option turns off the record macro mode and closes the current macro-file. Now you can play back the macro-file just created or any other available one.

Edit Macro

When you click on this item the standard Open dialog box named as Macro File to Edit appears. You can choose a macro-file you want to edit. Pressing Open invokes Notepad for you to edit the file specified.

Notes

  1. It is not recommended to edit macro-files with Notepad.

  2. Nested macro-files are not allowed.

  3. One way you can take advantage of macro-files is substituting a keysym for a key (defined in a keyboard definition file) with a keystroke sequence (defined in a macro-file). Appendix A, Keyboard Mapping File Format, describes normal keysym statement syntax. The extension to this is that a keysym can have the form of prefix MAC_ followed by a macro-file name. For example, the keysym statement in a kmf-file (with onF11 referencing to macro-file onF11.mac) may appear as

    KEY87 = MAC_onF11, 0xffc8; (XK_F11,XK_F11)


The Run Menu

This menu lets you launch a number of XSecurePro's programs listed below. To run one of these programs, click its name on the Run menu of XServer or from the X-clients Program Folder of the package (when XServer is running). (In these cases, the programs are called with parameters specified by XServer.)

XServer Settings

The XSettings utility changes information stored in the ini-file, including settings used by XServer.

Note that you have to restart XServer after having changed any settings made by XSettings (in the ini-file).

Font Manager

The Font Manager allows you to view fonts accessible for X clients in the current X-session and change font settings.

Telnet

The Telnet_SSH utility starts terminal emulation with a remote system running the Telnet or SSH1/SSH2 service.

XStartup

The Startup utility uses the REXEC, RSH, RLOGIN, or Telnet protocols to access hosts and then execute commands (e.g., to launch X clients).

LPR

The LPR utility prints files on printers attached to remote hosts on your network.

LPD

The LPD utility allows you to control access to your local (attached to your PC) and Microsoft-network-accessible printers for LPR-tasks from remote computers across your TCP/IP network.

FTP

The FTP utility transfers files to and from a remote computer running the FTP server.

ComSetup

The ComSetup utility makes communication settings relating to the TCP/IP transport interface.

Local X Clients

The XSecurePro package includes the following local X and Motif clients:

  • mwm (based on OpenMotif 2.0)
  • glxinfo (the GLX extension local X Client)
  • glxgears (the GLX extension local X Client)
  • xclock
  • xev
  • xfd
  • xfontsel
  • xkill
  • xlsfonts
  • xmodmap
  • xprop
  • xrdb
  • xset
  • xshowcmap
  • xwininfo

They have the same functionality and command line syntax as related remote (UNIX) ones, but were developed to be run under MS Windows, so you can use them the same way.

To run one of these programs, click its name on the Run menu of XServer or from the X-clients Program Folder of the package (when XServer is running). (In these cases, the clients are called with parameters specified by XServer.)

You can take advantage of the local X clients when remote (UNIX) ones are inaccessible or inconvenient to run.

For more information about these programs, please refer to Appendix F Local X and Motif Clients.


Other Commands on the X Client's Menu


The Refresh Item

This option is only available in the Multiple window mode. This option causes all X clients to re-display their windows.


The Local Refresh Item

This option lets you re-display all X clients' windows locally (by XServer, not X clients).


The Restart XServer Item

This option lets you restart XServer with closing all X clients and re-reading the ini-file used for the current X-session (that stores all XSecurePro's settings). The default ini-file is xwp.ini.


The Messages Item

This item displays server related information and error messages.


The About Item

This item displays information about your XSecurePro package.


The Help Item

This item displays the on-line help text of this chapter.


The Local Window Manager Item

This run-time setting is used in the Multiple window mode to switch on the local Window manager (for example, after XDM/CDE starts with faults).


The Readme & Ordering Info Item

This item uses Notepad to display the readme file.






Home | Product | Download | Order Now | Upgrade | Support | Pricing | Company Information | Contact Us


Labtam Copyright 1999 - 2009 LabtamTM Inc.